Jump to content
Neo Force Order Resurrection
RP

Bugs IPB

Recommended Posts

ici, pas le premier post (pourtant blindé de smileys), mais les suivants oui. En pratique, ça a l'air assez aléatoire.

Share this post


Link to post

Ha ouais !

 

A mon avis ça concerne tous les posts d'avant mise à jour, à partir du post de Ticlaz ce n'est plus le cas ... jvais enquêter

Share this post


Link to post

Pour ma part le messager et les notifications sont fonctionelles.

 

Merci :)

Share this post


Link to post

Quote du TEPOP, parce que c'est quand même pertinent pour ici.

 

Zone de test :

 

INPUT :

 

[url=http://www.apostrophe.com/attention.php?msg=pwnd'omgomgwtfbbq]omg[/url]
OUTPUT :

 

href="http://www.apostrophe.com/attention.php?msg=pwnd" omgomgwtfbbq"="">omg

 

Estimons-nous heureux que la balise code marche...

 

EDIT : HA HA.

EDIT² : AHAHAHAHAHAAA !!!

EDIT³ : Gnihihihi. Web theknologiz r so fnuny. Teehee.

 

Accessoirement, un second que j'ai découvert sur la shout à l'instant :

 

INPUT :

[url=http://perdu.com]:angry:[/url]
OUTPUT :

[url=http://perdu.com] :angry:[/url]
EDIT - Il ne le fait pas dans les posts, seulement dans la shoutbox (ou alors, c'est une séquence particulière dans l'URL qui trigger le problème).

 

C'est mineur, je le concède, mais c'est agaçant, parce que du coup ça fait apparaître des traits bleus ici et là, qu'il faut enlever à la main à chaque fois qu'on édite son message. (L'espace excédentaire n'apparait qu'au moment de l'édition.)

 

D'une manière générale, l'action d'éditer produit moins de bugs flagrants qu'avant la MàJ, mais elle altère définitivement le texte du message. Des espaces apparaissent et disparaissent à d'autres endroits autour des balises BBCode ; en outre, le fait d'utiliser l'éditeur WYSIWYG détruit de grandes quantités de BBCode, y compris dans les zones non éditées (sans parler des mochetés qu'il ajoute inutilement), mais je suppose que c'est une "feature".

Share this post


Link to post

Bordel de...

 

OK, alors :

 

1 - Dans la shoutbox (et uniquement là), toute balise url dont la valeur ne commence pas par "http://" est effacée du message au moment de la soumission.

 

INPUT :

[url=www.perdu.com]LIEN[/url]
OUTPUT

LIEN
Workaround : ajouter manuellement "http://" au début de chaque URL. J'ignore ce qu'il se passe si la ressource localisée ne passe pas par le protocole HTTP.

 

2 /!\ NE TESTEZ PAS CHEZ VOUS SI VOUS N'ÊTES PAS ADMIN /!\ - La sélection du thème "NFOR Mobile" empêche totalement l'affichage de toutes les pages webs du site. La suppression des cookies permet de réinitialiser le paramètre pour les guests, mais le thème est mémorisé pour les utilisateurs enregistrés.

 

Workaround : taper l'URL du PCA de mémoire dans sa barre d'adresse, se logger en admin et changer son thème à la main. Si on est pas admin, sangloter convulsivement et s'en vouloir de ne pas avoir écouté l'avertissement de Doc Windu.

 

 

...ce qui m'amène au point :

 

3 - Enregistrer un changement de thème dans le profil du PCA détruit le formatage HTML de la signature de l'utilisateur d'une manière que je qualifierais d'exotique. Celle-ci est ensuite instable et (sans doute suite à quelques aller-retours dans la BDD), continue d'évoluer suivant des critères mal définis au fil des affichages. Pour info, le code de ma signature actuelle a changé à au moins trois reprises, et est pour l'instant :

<div class="signature" data-memberid="2">
	
	<!--signature-cached-Wed, 19 Feb 2014 16:10:29 +0000--><!-- isHtml:1 --><!-- isHtml:1 --><a class='bbc_url' href='http://steamcommunity.com/id/dr_fred?l=english'><img src='http://91.121.113.133/~doc/Images/random/FYI.png' alt='Image IPB' class='bbc_img' /></a><br /><br /><br /><br /><span style='font-size: 8px;'>We did not invent the Algorithm. The Algorithm consistently finds Chaos<br /><br />The Algorithm is banned in China. The Algorithm killed Lycos.<br /><br />The Algorithm is under GPL. The Algorithm constantly finds Chaos.<br /><br />This is not the Algorithm. This is close.</span>
</div>
EDIT : Fixed. Mais bon, ça reste nainwak.

Share this post


Link to post

ACTUAL INPUT (ALTERED):

[url=http://www.perdu.com/]foo[sup]%5Bbar%5D[/sup][/url]
INPUT THAT DOESN'T BUG WITHIN CODE:

[url=http://www.perdu.com/]foo[sup] [ bar ] [/sup][/url]
OUTPUT:

foo%5Bbar%5D

 

Notez que quand j'édite le message, le cadre real input contient des crochets "[]" autour de bar, tout comme le bugless input, mais les crochets dans output ont été remplacés par %5B/%5D de manière permanente dans la BDD.

 

No furher explanation is required or will be provided.

 

En tout cas, on sait maintenant que l'ajout de balises "code" n'empêche pas le contenu d'être interprété en sous main comme du BBcode. Il modifie en revanche la façon dont il est interprété :

INPUT "[foo]" :

[foo]
INPUT sup("[foo]") :

[sup][foo][/sup]
INPUT url(perdu.com,"[foo]") :

[url=http://www.perdu.com]%5Bfoo%5D[/url]

Share this post


Link to post

Sans vouloir être méchant Doc, qu'est ce qu'en t'en a à foutre de mettre des crochets en exposant, hein ?

Share this post


Link to post

Ben, figure toi que si je suis tombé dessus, c'est justement parce que j'ai eu besoin de le faire et que ça a foiré. Et des liens en exposant entourés par des crochets, ça arrive tout le temps sur Wikipédia.

 

Et en plus, comme le montre mon edit, ça n'a en fait aucun rapport avec l'exposant, vu que ça se produit avec juste des balises URL.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×